Express is unavailable

Incident Report for Springbrook

Resolved

The issue has been resolved.
Posted Apr 29, 2026 - 13:13 PDT

Update

We are continuing to work on a fix.
Posted Apr 29, 2026 - 10:43 PDT

Identified

We have a cause identified and are working to correct it.
Posted Apr 29, 2026 - 09:41 PDT

Investigating

Half our customers are unable to access Express currently. Our engineering team is investigating.
Posted Apr 29, 2026 - 08:25 PDT
This incident affected: Springbrook Enterprise Cloud.