Springbrook Cloud - reports taking a long time to move from Scheduled to Processing

Incident Report for Springbrook

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 13:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 13:27 PDT

Investigating

We are currently investigating this issue.
Posted Mar 19, 2026 - 13:04 PDT
This incident affected: Cirrus and Springbrook Enterprise Cloud.