Springbrook Express - Printing is not available for a subset of users

Incident Report for Springbrook

Resolved

This incident has been resolved.
Posted May 20, 2026 - 12:55 PDT

Identified

Impacted agencies will have a short downtime to implement a fix. This will occur in the next 2 hours.
Posted May 20, 2026 - 09:59 PDT

Investigating

We are investigating an issue with printing in Springbrook Express impacting a subset of users. Printing is offline for these users while we troubleshoot.
Posted May 20, 2026 - 08:58 PDT
This incident affected: Springbrook Express Cloud.