Cirrus - Performance issues using Cirrus

Incident Report for Springbrook

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 11:39 PDT

Update

This was causing slow performance when using the application. This was also causing jobs/reports to take longer to start processing.
Posted Jul 28, 2026 - 10:51 PDT

Monitoring

We have identified an issue causing slow performance on one of our SQL servers. Performance should be returning to normal soon.
Posted Jul 28, 2026 - 10:45 PDT
This incident affected: Cirrus and Springbrook Enterprise Cloud.