CPO Scheduled Payments Not Processing
Incident Report for Springbrook
Resolved
Issue has been resolved and confirmed operational
Posted Jul 18, 2024 - 06:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2024 - 06:06 PDT
This incident affected: CivicPay (CivicPay Online Payment Processing).