Civicpay - Selectron IVR system down

Incident Report for Springbrook

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 10:37 PDT

Update

Selectron has notified us that the issue has been resolved and processing is returning to normal.
Posted Jul 17, 2026 - 08:59 PDT

Monitoring

We are monitoring an issue with IVR payments from Selectron.
Posted Jul 17, 2026 - 08:49 PDT
This incident affected: CivicPay (CivicPay Online Payment Processing).