Springbrook Cloud - reports taking a long time to move from Scheduled to Processing

Incident Report for Springbrook

Resolved

This incident has been resolved.
Posted May 27, 2026 - 11:54 PDT

Identified

We have identified an issue causing a backup in report processing.
Posted May 27, 2026 - 11:38 PDT
This incident affected: Cirrus and Springbrook Enterprise Cloud.