Springbrook cloud - Portal unaccessable

Incident Report for Springbrook

Resolved

We are still investigating the root cause.
Posted Mar 26, 2026 - 08:44 PDT

Update

We are continuing to investigate this issue.
Posted Mar 26, 2026 - 07:55 PDT

Update

The Portal is now accessible, we are still looking to see what happened.
Posted Mar 26, 2026 - 07:32 PDT

Investigating

We are currently investigating this issue.
Posted Mar 26, 2026 - 07:30 PDT
This incident affected: Cirrus and Springbrook Enterprise Cloud.