Springbrook Express - Printing is not available

Incident Report for Springbrook

Update

In an effort to improve our environment, we upgraded the servers. This has uncovered an issue with the printers. This issue does not appear in our staging environment. It also did not appear in the live environment initially. We have found a fix for the issue, which will require us to migrate everyone to new servers again. We are in the process of building this out. The new servers with the fix will be available by the end of day today. We will migrate everyone overnight.
Posted May 21, 2026 - 11:10 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2026 - 10:39 PDT

Investigating

The issue from yesterday is now impacting all users.
Posted May 21, 2026 - 09:45 PDT
This incident affects: Springbrook Express Cloud.